Book Tracker X 1.0 Documentation

For questions or comments, feel free to contact joe@valencio.com

Thank you for downloading Book Tracker X, a program designed to help you organize and
keep track of your book collection.

Download and Installation

Book Tracker X is distributed as a zipped archive. Double-click the Book Tracker X.zip file
to uncompress it if your browser doesn’t. Drop the Book Tracker X folder into your
Applications folder, or keep it on your desktop. The Book data folder must remain in the
same folder as the application.

Drag and Drop the Book Tracker X application icon into your Dock for easy access to your
book collection.

Adding Books with a Barcode Scanner

If you have a barcode scanner and an active internet connection, you can use multiple book
feature to add your books quickly to Book Tracker X.

Click File > Add Multiple Books (or hit Command-Shift-N), and the Multiple Book Entry
Screen will appear. Scan the UPC codes into the UPC text field, one per line. Most
barcode scanners (including the Kanescan) will insert an Return character after a barcode, so
you will not have to use the keyboard at all.

Once all the codes have been entered, click the Lookup UPC Codes button. UPC codes
found in the Amazon database will be displayed in the list.

Codes that are not found will be printed in blue, invalid codes will be printed in red.

Click the Add Books in List button to add the books from the list into your database.

Most barcode scanners on the market should work just fine with Book Tracker X, however
the only officially supported model is the Kanescan CCD Barcode Scanner, available from

http://www.kanecal.com. Please contact the author of Book Tracker X for instructions to
receive $20 off the Kanescan Barcode Scanner - total price $59 + S&H.



Adding Books Manually
Click the File > Add New Book (or hit Command-N), and fill in the fields.

The Add button to bring up the Amazon Search screen, but it can be set to bring up the
manual add screen. You can find this setting in Preferences > Behavior.

Selecting Books

To select a single book, click on the appropriate row in the book list on Book Tracker X’s
main screen.

Hold down the Shift key while clicking to select all book records between two points.

Hold down the Command key (Apple Key) while you click to select nonadjacent books.

Adding books Using Amazon

If you have an active internet connection, Book Tracker X can perform a title search using the
Amazon.com website.

From the menu, click Search > Amazon Lookup (or hit Command-B). You can search on
title, author, keywords, ISBN or UPC. Click Amazon Lookup (or hit the Enter key). Book
Tracker X will query the Amazon website. Search results are returned in the list. If more
than one result is found, click the book in the list to load the fields for each search result.

Click Add book to add the selected book to your database.

If you have a book already entered, and you'd like to look it up using Amazon.com, click the
Search Menu > Amazon Lookup [book Name] (or hit Shift-Command-B). The Amazon
search screen will open, and Book Tracker X will search the Amazon.com database for the
selected book title.

If you select multiple books, and click the Search Menu > Amazon Lookup X Selected
books, all titles from your selected books will be loaded into the combo box at the top of
the Amazon Search Screen. Select a book title from the pull-down menu, and click Amazon
Lookup to search for it.

Amazon is an independently operated website, and the author of Book Tracker X cannot
take responsibility for its content.

Editing books

Select a book from the main screen, and click Edit. Or, you may simply double-click a book.
Edit the fields and click Save.

You can edit multiple books by selecting them, and clicking the Edit button. The Multiple
book Edit screen will be displayed. Any fields that are the same among your selected
books will be filled in. To make a change to all selected books, click the checkbox next to
the appropriate field, and fill in the information. Click Save or Cancel.



Searching Your books

You can search any field in your book collection including user-defined fields using the seach
box on top of the main screen. Pick the field you want to search (from the magnifying glass
pull-down) and type in what you want to search for. Searches are not case sensitive.

Adding Your Own Custom Fields

Click Edit > Database Fields (or hit Command-D), and the Custom Fields window will
appear.

Type in a name for your new field in the Field Name text box, and click Add. Your new
field is instantly added to the database. To delete a field, click its name in the list, and click
the Delete button. You'll be asked to confirm the deletion.

Your custom fields can now be populated from the Edit book screen. You can show and
hide these fields using Display tab of the Preferences screen.

Printing Templates

Book Tracker X includes a custom WYSIWYG (What You See Is What You Get) layout
tool for printing your book records. Click File > Print > Template Manager (Shift-Command-
P) to show the Template Manager.

Select the Form to display the available templates for it. The forms are book List
Templates and Book Label Templates.

Included two built-in templates for each: book lists and book labels.

Book List Templates

Detailed List Example Template - Use this template to produce a detailed listing
of your book info
Title List Template - Use this to print a list of book titles only

Book Label Templates

Avery 8253 Example - Prints a book label with Title, Release Date, and My Rating
on 8253 labels
Avery 8160 Example - Prints a DVD label with book title only on 8160 labels.

Note - The label templates above are easily adapted to any Avery label stock.
Just edit the template, and select the appropriate Avery Product Code from the
pull-down menu. Save the template and give it a new name.

Click the New button on the Template Manager window to create a new blank template.
Click the Edit button (or double-click a template) to edit it. Click the Delete button to delete
a template that you've created - You cannot delete the built in templates. Click the Close
button to close the Template Manager window.



If you've created a new template, or you’re editing an existing template, you’ll use the
Template Editor. Drag a field from the Available Fields list into the layout window. Position
it where you want it to print. Field Properties will be applied to newly added fields. To edit
the properties of a field or to delete it, Control-Click it, and select the appropriate choice
from the contextual menu.

Click Save to save your template, and your new template will be available for printing the
appropriate form.

Click Close to close the Template Editor window.

Printing a List of Your Books

Click File > Print > Print List of X Displayed books (or hit Command-P). Select the
Template that you want to use to print. Click the Print One book per Page checkbox for a
separate page for each book. Click the Print button, and you will see the standard page
setup and print dialogs for your printer.

If are displaying the results of a search, only the displayed books will be printed.

Printing Information for a Selected book or books

Select a single book or multiple books on the main screen. Select Print Info for [book Title]
or Print Info for X Selected books (Command-Option-P). Select the Template that you
want to use to print. Click the Print One book per Page checkbox for a separate page for
each book. Click the Print button, and you will see the standard page setup and print
dialogs for your printer.

Printing Book Labels

Select a book or multiple books from the main screen that you want to print a label for. Click
File > Print > Print Book Label (or hit Command-L). Select the Template that you want to
use to print for your label. Click the Print button, and you will see the standard page setup
and print dialogs for your printer.

The Horizontal Offset and Vertical Offset fields are used to adjust the position of the label
printed on your label stock. If the print is not correctly positioned on your label sheets, you
need to make adjustments to these settings. Each pixel is 1/72”.

Creating Web Pages From Your Database

Click File > Export > Web Pages (or hit Command-H) and the Export book Database to
HTML dialog will be displayed.

File Name will be proceeded by a page number, so if you keep the default, your pages
will be named Book Tracker X Books_1.html, Book Tracker X Books_2.html, etc.

Rows and columns determine how your books will be displayed on the web page. This is
a regular html table. Depending upon how many rows and columns you set, the number of
HTML pages will change.



Table Border Width is the width in pixels of the table border. Set it to 0 (zero) for an
invisible table.

Check or uncheck the fields that you wish to include. Text attributes for each field can also
be set.

Click the Browse button to save your web pages in a folder other than Documents.

Lending and Returning Books

Select the book or books that you want to lend out. Click the Loan button, and select your
friend from the pull-down list, or enter a new name. Click the Loan button.

In the preferences, you can check Show Address Book contacts when loaning books on the
Behavior tab. When loaning books, you’ll see the names of people in your Address
Book.

When the book has been returned, select it on the main screen, and hit the Return button.

The X books on Loan button will display a menu list of your loaned books. Click on them to
jump to a loaned book.

Friends and Formats

Delete friends (who have not returned your books!) by selecting Edit > Friends. Friends
can be added and removed from this window.

Importing and Exporting

Click File > Export > Text File (or hit Command-F) and the Export book Database to Text
File dialog will be displayed.

Your database will be exported as a tab-delimited text file including the fields in the order
that you have checked in Preferences > Display.

Click Export, and you’ll see a standard Save File dialog for your file. The first line of the
exported file will contain the tag <Book Tracker X Key> followed by a tab-delimited list of
the field names. This line tells Book Tracker X the names of the fields and their position in
the exported file.

To import a tab-delimited text file, click File > Import... (or hit Command-I) and you'll see a
standard Open File Dialog. Select the file that you want to import. The file must contain a
key to tell Book Tracker X the order of the fields.

If the file contains a key, you'll see the Import File Preview dialog, which will show you how
the file will be imported. Custom fields will be added to the database if necessary. Click
Import or Cancel.



Linking eBooks or Audio Books to Book Tracker X

From the Add New book or Edit book screen, click the Browse button next to the Path text
box. Navigate to the file you wish to link to, and click Open. Click the Save button.

If you have done the above step, the Open Book button will appear when you click on the
book from the main screen. Click it, and the linked file will open using your default
application.

Preferences

Display
Drag and drop the individual fields to reorder them on the main window.
Check them to show, or uncheck them to hide their display on the main
screen. Set the column alignments here also.

Appearance
Here you can select the colors for highlighting books you want to own or used
to own.

Behavior

Add Button brings up Amazon screen
If this is checked, the Add button will bring up the Amazon search
screen.
If unchecked, the manual add screen will be shown. You can still
access either screen from the keyboard shortcuts.

Show Address Book Contacts when loaning books
Check this option to show names in the Mac OS X Address Book
when loaning books

Show Value of displayed Books
Using the price field

| really appreciate all of your comments and suggestions! I'm always looking into features to
add to the next version of Book Tracker X, so if you have any ideas, please let me know.

Change History
1.3 - 12/3/2004

Initial public release.

For questions or comments, feel free to contact joe@valencio.com

Copyright 2004, Valencio Productions



